Intermittent Access to Crowdsource

Incident Report for Perceptyx EU

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 03:34 UTC

Investigating

We are currently experiencing intermittent access issues with our Crowdsource application due to an ongoing outage affecting our cloud provider, Heroku. You can follow the status of this incident here: https://status.heroku.com/incidents/2822.

Our team is actively monitoring the situation and will provide updates as they become available.
Posted Jun 10, 2025 - 20:39 UTC
This incident affected: Listen (Crowdsourcing).